July 23, 2014, 09:42:39 AM
News: Hey, we have forums!
  Pages: [1]
Print
Author Topic: Aquaria mouse pointer problem solved  (Read 4545 times)
archmage
Mini Bit
**
Posts: 2


View Profile Email
« on: November 24, 2011, 07:51:22 PM »

Hi,

I bought the Introversion Humble Bundle to play Aquaria on my 64-bit Ubuntu 11.04 system. Unfortunately the mouse did not work, to the point of making the game unplayable.

First of all it was not possible to change resolution, because the mouse pointer kept moving back to "no". Far more seriously, while in game the character kept moving towards up and left.

A long search on the net provided no clear answer; it seems some people have the same problem on Windows and OSX too. On ubuntu some suggest to disable the package "unclutter" to solve the issues, but I did not have that installed at all.

My solution to the problem was to modify the ~/.Aquaria/preferences/usersettings.xml file. Using any text editor, change the line:

<JoystickEnabled on="1" />

to:

<JoystickEnabled on="0" />

The game is now playable  Cool


ps: this problem was the cause of a lot of frustration for me, so I registered on this forum to post it - sorry if it has been posted already.
Logged
False.Genesis
Global Moderator
Monster Bit
**********
Posts: 370


Rabid prototyping

489981073
View Profile WWW
« Reply #1 on: November 24, 2011, 09:28:11 PM »

This is interesting.
My guess: Either you had a bad joystick/gamepad plugged in, or you have a touchscreen that is recognized as joystick and sends bad infos (this is the case for a friend's subnotebook).
Or another device that sends bogus joystick infos.

Might be helpful for others if one of these is true and you'd confirm it.
Logged

archmage
Mini Bit
**
Posts: 2


View Profile Email
« Reply #2 on: November 24, 2011, 10:26:39 PM »

No, I don't have anything of the kind - no joystick/ touchpad/ gamepad/ touchscreen/ etc. I have a desktop machine. Thanks to your comment, though, I discovered the following:

The only "unusual" peripheral I have is my (old) Logitech G15. Even though I do not use macros or any other special keyboard features, the cursor problem goes away if I turn on Joystick support in Aquaria and turn off the G15 system service. I am using the package gnome15 (version 0.7.11-1) from www.gnome15.org.

Given that I have no problems whatsoever with the keyboard in any other software (windows and linux), I would say this still counts as a bug Smiley If I can do something to help troubleshoot it, let me know.

It would be interesting to know if other people that reported the exact same problem have a G15!
Logged
Elnareen
Newbit
*
Posts: 1


View Profile
« Reply #3 on: December 18, 2011, 12:11:01 PM »

Hi,

I encountered the same problem on Archilinux 64 bits with a logitech G500 mouse.
No joystick was ever connected to the system, but since the X11 evdev driver is used for both gamer mouses
and a lot of others USB input devices such as gamer keyboards and joysticks,  it may be a clue:

Disabling joystick support in ~/.Aquaria/preferences/usersettings.xml worked here too.
Logged
  Pages: [1]
Print
Jump to: