December 04, 2020, 05:11:30 AM
News: Hey, we have forums!
  Pages: [1]
Print
Author Topic: "Swim" key only works for initial burst  (Read 7383 times)
Martoon
Mini Bit
**
Posts: 7


View Profile
« on: December 17, 2007, 06:22:03 PM »

For mouse-controlled action games, I strongly prefer to use keyboard keys for actions and not mouse buttons.  Constantly clicking and/or holding down mouse buttons gives me RSI in a hurry, and I also get less fine control of the mouse if I have to hold downward pressure on the buttons while moving it.  Things go much better if I can lightly glide the mouse around with my right hand and do any keypresses with my left hand.

Aquaria almost lets me do this.  There are action keys for swim and fire.  Unfortunately, the swim key only works for the speed burst you can do every second or so.  It doesn't follow the mouse cursor around if you hold the key down.

I just bought this game, and I'd be much indebted to you if I could finish it without hand and forearm pain.  Smiley
Logged
Alec
Administrator
Dream Bit
**********
Posts: 2211



View Profile Email
« Reply #1 on: December 17, 2007, 06:34:31 PM »

I think you could probably just bind a key to "left mouse button" in key config?

I don't have time to try it right now, but it might work.
Logged

Martoon
Mini Bit
**
Posts: 7


View Profile
« Reply #2 on: December 17, 2007, 08:00:16 PM »

I think you could probably just bind a key to "left mouse button" in key config?

I don't have time to try it right now, but it might work.
On the key config screen, the left/right mouse equiv. rows have joystick buttons in the third column and 0's in the first two columns.  If I click one of the 0's, it plays the "you can't do this" sound.

[edit]Also tried editing usersettings.xml directly, setting them to KEY_Z and KEY_X.  They now show that way on the config screen, but still have no effect in game.
« Last Edit: December 17, 2007, 08:12:08 PM by Martoon » Logged
Alec
Administrator
Dream Bit
**********
Posts: 2211



View Profile Email
« Reply #3 on: December 17, 2007, 08:49:52 PM »

Oh okay... I'll see if I can change that. Smiley
Logged

doninss
Bit
***
Posts: 17



View Profile
« Reply #4 on: December 18, 2007, 02:02:57 AM »

Holding L mouse button makes me hurt as well. I zipped a few Autohotkey scripts, one of which  may suffice as a work-around 'till Alec changes things. http://www.genericgamer.com/misc/Aqua_Ahk.zip

The .exes are stand alone (run one of them before entering the game). There are two each for the x, z, and spacebar keys. One to convert the key to L mouse button, and one to toggle L mouse down and up. Run one before entering the game, but be aware the key will be (and stay) changed until you exit. (Right click on the little green H in the tray and click "Exit")

If you'd rather download Autohotkey (link), there are also scripts. (If autohotkey is installed, just run the scripts instead.) You could also just write the scripts yourself, they are very simple.


« Last Edit: December 18, 2007, 02:08:58 AM by doninss » Logged
Martoon
Mini Bit
**
Posts: 7


View Profile
« Reply #5 on: December 18, 2007, 04:25:54 AM »

Thanks!
Logged
  Pages: [1]
Print
Jump to: